Latest Firefox Update
Incident Report for WorkCast
Resolved
A fix has been identified and will be updated as part of an upcoming platform release.
Posted Dec 20, 2017 - 16:59 GMT
Update
Our engineers are still investigating a permanent fix for this Firefox update for auditorium pages and event embed code which gives some users an intermittent experience. A temporary solution has been identified.
Posted Nov 30, 2017 - 10:47 GMT
Investigating
We are currently investigating a recent Firefox update that is causing intermittent issues with live streams. Our engineers are looking into this and we will update you as soon as possible.
Posted Nov 22, 2017 - 18:11 GMT