Event Confirmation/Reminder/Presenter Login Emails
Incident Report for WorkCast
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 08:51 BST
Investigating
Our service provider is experiencing some delays in sending emails.
This may cause a delay in some event confirmation, event reminder and presenter login details emails from being delivered

Our Engineers are monitoring the situation through our service provider updates
https://status.mailgun.com/incidents/9djjsl006cf6
Posted Sep 21, 2022 - 19:38 BST