Duplicate drop-down fields showing on registration pages in latest version of Chrome/Edge
Incident Report for WorkCast
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 07:30 GMT
Identified
The issue has been identified and a fix will be deployed between 07:00 - 07:45 UTC, 19th November.

We have ensured no events will be running at this time and there is no expected disruption to registrations either
Posted Nov 18, 2024 - 14:08 GMT
Investigating
We are currently investigation this issue, please note this does not affect attendees ability to register
Posted Nov 18, 2024 - 13:07 GMT
This incident affected: Auditorium & Registration Forms.