Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 06:00 BST
Scheduled
This release - provisionally scheduled for 24 October - will introduce: - Improved streaming quality with adaptive bitrate, ensuring viewers always experience the best possible quality for their connection. - Expanded producer controls in Studio.
It’s still the same great product which offers you full sessions using pre-recorded media that play out automatically at a specific time and date, complete with Automated Polling and all the familiar functionality you rely on - now with even more flexibility and quality enhancements.
We'll share more details soon, so please ensure you're subscribed to our marketing emails for updates following the rollout.
As always, if you have any questions regarding the updates, please reach out to your Account Manager.
---
There may be periods of downtime during this work, but we’ve ensured that no live events are occurring at this time.
Posted Oct 07, 2025 - 16:08 BST
This scheduled maintenance affected: WorkCast Creator, WorkCast Studio, and Auditorium & Registration Forms.