We have a planned release scheduled for tomorrow at 07:00 UTC to deploy a fix for the issue affecting attendees viewing simulive scheduled replays on WorkCast embed.
Thank you for your patience while we complete these updates.
Posted Oct 23, 2025 - 19:39 BST
Monitoring
A fix for auditoriums has been implemented and we are monitoring the results.
We are testing a fix for embed and will look to release it shortly.
Posted Oct 23, 2025 - 09:33 BST
Update
We have a planned release scheduled for tomorrow at 07:30 UTC to deploy a fix for the issue affecting attendees viewing simulive scheduled replays on WorkCast auditoriums.
We're continue work on an embed update, which will be released separately once ready.
Thank you for your patience while we complete these updates.
Posted Oct 22, 2025 - 13:16 BST
Update
We are continuing to work on a fix for this issue.
Posted Oct 22, 2025 - 09:42 BST
Update
We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 17:57 BST
Update
We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 14:24 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 10:45 BST
Investigating
We're aware of an issue affecting playback for simulive scheduled replay events on iPhones.
This issue impacts both embedded players and WorkCast auditoriums, but only for users accessing them on iPhone devices.
Posted Oct 21, 2025 - 10:44 BST
This incident affected: Auditorium & Registration Forms and WorkCast Embed.